[ 
https://issues.apache.org/jira/browse/HIVE-21312?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16780241#comment-16780241
 ] 

Zoltan Haindrich commented on HIVE-21312:
-----------------------------------------

it looks good so far, I've collected some notes:

* use try-with-resources instead of: {{in = new 
Input(fs.open(file.getPath()));}} and closing it?
* use the return value of the future instead of returning just null; and that 
way you will not need the "concurrectqueue" as the executor has it built in 
already.
* statsMap should be a local variable; I don't understand why it was a field
* the log messages will come from a totally different thread than it have 
logged from before; this will make the log less readable - log them after they 
are back in the original thread
* is there a reason to raise "read stats" log messages from trace to info? I 
think it will just make noise 
* I think it would be better to use cachedthreadpool - in case we are reading 
just a few files - there is no reason to launch more threads


> FSStatsAggregator::connect is slow
> ----------------------------------
>
>                 Key: HIVE-21312
>                 URL: https://issues.apache.org/jira/browse/HIVE-21312
>             Project: Hive
>          Issue Type: Improvement
>          Components: Statistics
>            Reporter: Rajesh Balamohan
>            Assignee: Rajesh Balamohan
>            Priority: Trivial
>         Attachments: HIVE-21312.1.patch, HIVE-21312.2.patch, 
> HIVE-21312.3.patch
>
>




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to