Andrey Mashenkov created IGNITE-15341:
-----------------------------------------

             Summary: Table API. Rename confusing method getOrCreateTable.
                 Key: IGNITE-15341
                 URL: https://issues.apache.org/jira/browse/IGNITE-15341
             Project: Ignite
          Issue Type: Improvement
            Reporter: Andrey Mashenkov
             Fix For: 3.0.0-alpha3


`GetOrCreateTable` method accepts table configuration as an argument.
However, it is not clear if there is a guarantee the returned table will have 
the configuration equals to the provided one.
 
Let's rename the method to `createTableIfNotExists` to avoid confusion.
Note: thin client API must be fixed as well (if it is affected).



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to