[ 
https://issues.apache.org/jira/browse/IGNITE-15355?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17404113#comment-17404113
 ] 

Ignite TC Bot commented on IGNITE-15355:
----------------------------------------

{panel:title=Branch: [pull/9347/head] Base: [master] : No blockers 
found!|borderStyle=dashed|borderColor=#ccc|titleBGColor=#D6F7C1}{panel}
{panel:title=Branch: [pull/9347/head] Base: [master] : New Tests 
(1)|borderStyle=dashed|borderColor=#ccc|titleBGColor=#D6F7C1}
{color:#00008b}PDS 4{color} [[tests 
1|https://ci.ignite.apache.org/viewLog.html?buildId=6151145]]
* {color:#013220}IgnitePdsTestSuite4: 
NoUnnecessaryRebalanceTest.testNoRebalanceOnCacheCreation - PASSED{color}

{panel}
[TeamCity *--> Run :: All* 
Results|https://ci.ignite.apache.org/viewLog.html?buildId=6151172&buildTypeId=IgniteTests24Java8_RunAll]

> Test method corruptDataEntry works incorrecly for in-memory and persistence 
> caches
> ----------------------------------------------------------------------------------
>
>                 Key: IGNITE-15355
>                 URL: https://issues.apache.org/jira/browse/IGNITE-15355
>             Project: Ignite
>          Issue Type: Test
>            Reporter: Maxim Muzafarov
>            Assignee: Maxim Muzafarov
>            Priority: Major
>             Fix For: 2.12
>
>          Time Spent: 0.5h
>  Remaining Estimate: 0h
>
> There are several issues with the {{corruptDataEntry}} method which are need 
> to be fixed:
> - public package for org.apache.ignite.TestStorageUtils#corruptDataEntry 
> needs to change to internal
> - duplicated code org.apache.ignite.TestStorageUtils#corruptDataEntry and 
> org.apache.ignite.util.GridCommandHandlerClusterByClassTest#corruptDataEntry
> - corruptDataEntry can't be used 'as is' for in-memory and persistence caches 
> since it has dependency at the {{applyUpdate}} which has meaning only for 
> persistence.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to