[ 
https://issues.apache.org/jira/browse/IGNITE-16350?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Kirill Tkalenko updated IGNITE-16350:
-------------------------------------
    Description: 
This task should be used for TODO links in code. All suggestions must be stated 
in the list below or in TODO in code, or both:
 * {{IgniteUtils#hexInt}} and {{IgniteUtils#hexLong}} should be moved to other 
class like {{IgniteStringUtils}} and possible renamed;
 * Improve javadoc on the {{PageMemory}} class;
 * Describe {{page}} and {{pageAddr}} naming convention in {{{}PageSupport{}}};
 * Rename and properly document {{PageMemory#systemPageSize}} and 
{{{}PageMemory#realPageSize{}}};
* Replace *DataStructure#rnd* to {{private final IntUnaryOperator rng;}}
* Get rid of *AbstractFreeList#minSizeForDataPage*;
* Consider not blocking all pages in *PagesList#putReuseBag*;
* Think about all the system properties from *PagesList.PagesCache*;
* Optimize *PagesListNodeIo#removePage*;
* Refactor *BplusIo#canGetRow*;
* Output all first page ID by levels in *BplusMetaIo#printPage*;
* Make *BplusTree#minFill* and *BplusTree#maxFill* configurable (0 <= minFill 
<= maxFill <= 1);
* Make *BplusTree#IGNITE_BPLUS_TREE_LOCK_RETRIES* configurable;
* Make *BplusTree#innerIos* and *BplusTree#leafIos* final;
* Add *ConcurrentLinkedHashMap* implementation to 
*BplusTreeSelfTest.TestPageLockListener#locks*;

  was:
This task should be used for TODO links in code. All suggestions must be stated 
in the list below or in TODO in code, or both:
 * {{IgniteUtils#hexInt}} and {{IgniteUtils#hexLong}} should be moved to other 
class like {{IgniteStringUtils}} and possible renamed;
 * Improve javadoc on the {{PageMemory}} class;
 * Describe {{page}} and {{pageAddr}} naming convention in {{{}PageSupport{}}};
 * Rename and properly document {{PageMemory#systemPageSize}} and 
{{{}PageMemory#realPageSize{}}};
* Replace *DataStructure#rnd* to {{private final IntUnaryOperator rng;}}
* Get rid of *AbstractFreeList#minSizeForDataPage*;
* Consider not blocking all pages in *PagesList#putReuseBag*;
* Think about all the system properties from *PagesList.PagesCache*;
* Optimize *PagesListNodeIo#removePage*;
* Refactor *BplusIo#canGetRow*;
* Output all first page ID by levels in *BplusMetaIo#printPage*;
* Make *BplusTree#minFill* and *BplusTree#maxFill* configurable (0 <= minFill 
<= maxFill <= 1);
* Make *BplusTree#IGNITE_BPLUS_TREE_LOCK_RETRIES* configurable;
* Make *BplusTree#innerIos* and *BplusTree#leafIos* final;


> [Native Persistence 3.0] Post-porting renames and improvements
> --------------------------------------------------------------
>
>                 Key: IGNITE-16350
>                 URL: https://issues.apache.org/jira/browse/IGNITE-16350
>             Project: Ignite
>          Issue Type: Improvement
>            Reporter: Ivan Bessonov
>            Priority: Major
>              Labels: ignite-3
>             Fix For: 3.0.0-alpha5
>
>
> This task should be used for TODO links in code. All suggestions must be 
> stated in the list below or in TODO in code, or both:
>  * {{IgniteUtils#hexInt}} and {{IgniteUtils#hexLong}} should be moved to 
> other class like {{IgniteStringUtils}} and possible renamed;
>  * Improve javadoc on the {{PageMemory}} class;
>  * Describe {{page}} and {{pageAddr}} naming convention in 
> {{{}PageSupport{}}};
>  * Rename and properly document {{PageMemory#systemPageSize}} and 
> {{{}PageMemory#realPageSize{}}};
> * Replace *DataStructure#rnd* to {{private final IntUnaryOperator rng;}}
> * Get rid of *AbstractFreeList#minSizeForDataPage*;
> * Consider not blocking all pages in *PagesList#putReuseBag*;
> * Think about all the system properties from *PagesList.PagesCache*;
> * Optimize *PagesListNodeIo#removePage*;
> * Refactor *BplusIo#canGetRow*;
> * Output all first page ID by levels in *BplusMetaIo#printPage*;
> * Make *BplusTree#minFill* and *BplusTree#maxFill* configurable (0 <= minFill 
> <= maxFill <= 1);
> * Make *BplusTree#IGNITE_BPLUS_TREE_LOCK_RETRIES* configurable;
> * Make *BplusTree#innerIos* and *BplusTree#leafIos* final;
> * Add *ConcurrentLinkedHashMap* implementation to 
> *BplusTreeSelfTest.TestPageLockListener#locks*;



--
This message was sent by Atlassian Jira
(v8.20.1#820001)

Reply via email to