Konstantin Orlov created IGNITE-20284:
-----------------------------------------
Summary: CatalogManager refactoring
Key: IGNITE-20284
URL: https://issues.apache.org/jira/browse/IGNITE-20284
Project: Ignite
Issue Type: Improvement
Reporter: Konstantin Orlov
Currently, the code related to parameter handling and validation resides in the
CatalogManager class. This leads to over-complication of the manager code and
conflicts when multiple people add new commands at the same time.
Let's redesign this class to better separate the code responsible for
generating update to the catalog and applying these updates.
Proposed solution as follow:
* Rename *Param classes to Command
* Move logic of validation on generation of UpdateEntry to these command
* Remove all create|alter|drop methods from CatalogManager, replace it with
single execute(Command)
This ticket is an umbrella. The refactoring should be made in separate tickets
on per command basis.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)