Konstantin Orlov created IGNITE-24924:
-----------------------------------------

             Summary: Sql. Rename TransactionTracker to better reflect semantic
                 Key: IGNITE-24924
                 URL: https://issues.apache.org/jira/browse/IGNITE-24924
             Project: Ignite
          Issue Type: Improvement
          Components: sql
            Reporter: Konstantin Orlov


{{TransactionTracker}} is tracking operation within a particular transaction 
rather than transaction itself. Therefore it suggested to change the interface 
in the following way:
{code}
public interface TransactionalOperationTracker {
    boolean registerOperationStart(InternalTransaction tx);
    void registerOperationFinish(UUID txId);
}
{code}



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to