[ 
https://issues.apache.org/jira/browse/IGNITE-5899?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16110940#comment-16110940
 ] 

Vladimir Ozerov commented on IGNITE-5899:
-----------------------------------------

[~ptupitsyn], my comments:
1) Please rename all classes from {{Platform*}} to {{Client*}}, as it is not 
about platforms at all.
2) Parser looks useless to me at the moment. We have clear separation of 
concerns between parser and handler:
- Parser should construct request object with all necessary data inside. If 
this is a GET request, then it should produce something like 
{code}
class ClientGetRequest {
    long reqId,
    int cacheId;
    Object key;
}
{code}
- Handler must process request and produce a response, e.g.:
{code}
class ClientGetResponse {
    long reqId;
    Object val;
}
{code}

> Thin client: cache.Get for primitives
> -------------------------------------
>
>                 Key: IGNITE-5899
>                 URL: https://issues.apache.org/jira/browse/IGNITE-5899
>             Project: Ignite
>          Issue Type: Task
>          Components: platforms
>            Reporter: Pavel Tupitsyn
>            Assignee: Pavel Tupitsyn
>              Labels: .NET
>             Fix For: 2.2
>
>
> Implement {{cache.Get}} for primitive data types via thin client protocol.
> This will include:
> * New client type in {{SqlListenerNioListener}}
> * {{PlatformRequestHandler implements SqlListenerRequestHandler}}, 
> {{PlatformMessageParser implements SqlListenerMessageParser}}
> * Integration test in .NET (just because .NET is the first platform to adopt 
> this; we could do tests in Java as well, but this is redundant for now)
> Support only primitive types for now to avoid dealing with bynary type 
> metadata, schemas, compact footers, etc.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to