[ 
https://jira.codehaus.org/browse/MENFORCER-184?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Martin Höller updated MENFORCER-184:
------------------------------------

    Description: 
With the standard rules enforce-exist and enforce-dont-exist it is possible to 
ensure files exist resp. do not exist. Unfortunately the files must be 
specified with the exact name! Wildcards are currently not supported.

My concrete use case is, I wan't to enforce, that no *Test.class files exist in 
some output-directory. This is currently not possible. Some configuration like 
the following should be supported:
{{              <rules>
                <requireFilesDontExist>
                  <message>Integration-Test classes must be named *IT but *Test 
classes exist.</message>
                  <includes>

                    
<include>${project.build.testOutputDirectory}/at/co/xss/lib/service/mail/DummyTest.*</include>
                  </includes>
                </requireFilesDontExist>
              </rules>}}


  was:
With the standard rules enforce-exist and enforce-dont-exist it is possible to 
ensure files exist resp. do not exist. Unfortunately the files must be 
specified with the exact name! Wildcards are currently not supported.

My concrete use case is, I wan't to enforce, that no *Test.class files exist in 
some output-directory. This is currently not possible.


> enforce-(don't)-exist rules should support wildcards
> ----------------------------------------------------
>
>                 Key: MENFORCER-184
>                 URL: https://jira.codehaus.org/browse/MENFORCER-184
>             Project: Maven Enforcer Plugin
>          Issue Type: New Feature
>          Components: Standard Rules
>            Reporter: Martin Höller
>
> With the standard rules enforce-exist and enforce-dont-exist it is possible 
> to ensure files exist resp. do not exist. Unfortunately the files must be 
> specified with the exact name! Wildcards are currently not supported.
> My concrete use case is, I wan't to enforce, that no *Test.class files exist 
> in some output-directory. This is currently not possible. Some configuration 
> like the following should be supported:
> {{              <rules>
>                 <requireFilesDontExist>
>                   <message>Integration-Test classes must be named *IT but 
> *Test classes exist.</message>
>                   <includes>
>                     
> <include>${project.build.testOutputDirectory}/at/co/xss/lib/service/mail/DummyTest.*</include>
>                   </includes>
>                 </requireFilesDontExist>
>               </rules>}}



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Reply via email to