[ 
https://issues.apache.org/jira/browse/NIFI-11069?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Zsihovszki Krisztina updated NIFI-11069:
----------------------------------------
    Description: 
PutDrobox processor cancels the upload in shutdown() (onUnscheduled) method.

This upload cancellation is not need since the processor is properly stopped if 
user terminates the processor.

PutDropbox uses "fail", "overwrite" and "ignore" conflict resolution 
strategies. Other PutX processors use the name "replace" instead of "overwrite".

PutDropbox should follow the same naming convention.

Also in scope of NIFI-11068 the conflict resolution strategies will be 
extracted to a common class.

 

  was:
PutDrobox processor cancels the upload in shutdown() (onUnscheduled) method.

This upload cancellation is not need since the processor is properly stopped if 
user terminates the processor.

PutDropbox uses "fail", "overwrite" and "ignore" conflict resolution 
strategies. Other PutX processors use the name "replace" instead of "overwrite".

PutDropbox should follow the same naming convention.

Also in scope of NIFI-11068 the conflict resolution strategies will be excluded 
to a common class.


 


> PutDropbox: remove upload cancellation, unify conflict resolution strategy 
> naming
> ---------------------------------------------------------------------------------
>
>                 Key: NIFI-11069
>                 URL: https://issues.apache.org/jira/browse/NIFI-11069
>             Project: Apache NiFi
>          Issue Type: Improvement
>          Components: Extensions
>            Reporter: Zsihovszki Krisztina
>            Assignee: Zsihovszki Krisztina
>            Priority: Major
>          Time Spent: 20m
>  Remaining Estimate: 0h
>
> PutDrobox processor cancels the upload in shutdown() (onUnscheduled) method.
> This upload cancellation is not need since the processor is properly stopped 
> if user terminates the processor.
> PutDropbox uses "fail", "overwrite" and "ignore" conflict resolution 
> strategies. Other PutX processors use the name "replace" instead of 
> "overwrite".
> PutDropbox should follow the same naming convention.
> Also in scope of NIFI-11068 the conflict resolution strategies will be 
> extracted to a common class.
>  



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to