Tsz-wo Sze created HDDS-15909:
---------------------------------

             Summary: Refactor OzoneManagerLock
                 Key: HDDS-15909
                 URL: https://issues.apache.org/jira/browse/HDDS-15909
             Project: Apache Ozone
          Issue Type: Improvement
          Components: OM
            Reporter: Tsz-wo Sze
            Assignee: Tsz-wo Sze


{code:java}
//OzoneManagerLock
  private final Map<Class<? extends Resource>,
      Pair<Map<Resource, Striped<ReadWriteLock>>, ResourceLockTracker>> 
resourcelockMap;
{code}
The resourcelockMap above is
 - inefficient: use a Map (the outer map) for only two elements.
 - hard to read/understand: too many layers
 - Apache Commons Pair (see HDDS-15908).
 - Not type safe: ResourceLockTracker is generic



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to