Yadong Qi created SPARK-3285:
--------------------------------

             Summary: Using values.sum is easier to understand than using 
values.foldLeft(0)(_ + _)
                 Key: SPARK-3285
                 URL: https://issues.apache.org/jira/browse/SPARK-3285
             Project: Spark
          Issue Type: Test
          Components: Examples
    Affects Versions: 1.0.2
            Reporter: Yadong Qi


def sumB >: A: B = foldLeft(num.zero)(num.plus)
Using values.sum is easier to understand than using values.foldLeft(0)(_ + ), 
so we'd better use values.sum instead of values.foldLeft(0)( + _)



--
This message was sent by Atlassian JIRA
(v6.2#6252)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscr...@spark.apache.org
For additional commands, e-mail: issues-h...@spark.apache.org

Reply via email to