[ 
https://issues.apache.org/jira/browse/SPARK-3441?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14125936#comment-14125936
 ] 

Sandy Ryza commented on SPARK-3441:
-----------------------------------

I'll add mention that this can be used to get Hadoop-style shuffle.  Because we 
opted not to provide the grouping, the API isn't ideal for porting workloads 
from Hadoop - the amount of code required to replicate the Hadoop shuffle 
semantics is probably more than we can fit in the Javadoc.  Not opposed to 
adding a note that it can be used as a building block.

I considered a version without a partitioner, but I couldn't think of a 
situation where one would care that records are sorted within a partition, but 
not need to be specific about what keys end up in what partitions.  Anything 
you can think of that I'm missing?

> Explain in docs that repartitionAndSortWithinPartitions enacts Hadoop style 
> shuffle
> -----------------------------------------------------------------------------------
>
>                 Key: SPARK-3441
>                 URL: https://issues.apache.org/jira/browse/SPARK-3441
>             Project: Spark
>          Issue Type: Improvement
>          Components: Documentation, Spark Core
>            Reporter: Patrick Wendell
>            Assignee: Sandy Ryza
>
> I think it would be good to say something like this in the doc for 
> repartitionAndSortWithinPartitions and add also maybe in the doc for groupBy:
> {code}
> This can be used to enact a "Hadoop Style" shuffle along with a call to 
> mapPartitions, e.g.:
>    rdd.repartitionAndSortWithinPartitions(part).mapPartitions(...)
> {code}
> It might also be nice to add a version that doesn't take a partitioner and/or 
> to mention this in the groupBy javadoc. I guess it depends a bit whether we 
> consider this to be an API we want people to use more widely or whether we 
> just consider it a narrow stable API mostly for Hive-on-Spark. If we want 
> people to consider this API when porting workloads from Hadoop, then it might 
> be worth documenting better.
> What do you think [~rxin] and [~matei]?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscr...@spark.apache.org
For additional commands, e-mail: issues-h...@spark.apache.org

Reply via email to