[
https://issues.apache.org/jira/browse/SPARK-1547?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14152101#comment-14152101
]
Joseph K. Bradley commented on SPARK-1547:
------------------------------------------
This will be great to have! The WIP code and the list of to-do items look good
to me.
Small comment: For the losses, it would be good to rename "residual" to either
"pseudoresidual" (following Friedman's paper) or to "lossGradient" (which is
more literal/accurate). It would also be nice to have the loss classes compute
the loss itself, so that we can compute that at the end (and later track it
along the way).
> Add gradient boosting algorithm to MLlib
> ----------------------------------------
>
> Key: SPARK-1547
> URL: https://issues.apache.org/jira/browse/SPARK-1547
> Project: Spark
> Issue Type: New Feature
> Components: MLlib
> Affects Versions: 1.0.0
> Reporter: Manish Amde
> Assignee: Manish Amde
>
> This task requires adding the gradient boosting algorithm to Spark MLlib. The
> implementation needs to adapt the gradient boosting algorithm to the scalable
> tree implementation.
> The tasks involves:
> - Comparing the various tradeoffs and finalizing the algorithm before
> implementation
> - Code implementation
> - Unit tests
> - Functional tests
> - Performance tests
> - Documentation
> [Ensembles design document (Google doc) |
> https://docs.google.com/document/d/1J0Q6OP2Ggx0SOtlPgRUkwLASrAkUJw6m6EK12jRDSNg/]
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]