[
https://issues.apache.org/jira/browse/TAJO-605?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13991480#comment-13991480
]
Hudson commented on TAJO-605:
-----------------------------
SUCCESS: Integrated in Tajo-master-build #212 (See
[https://builds.apache.org/job/Tajo-master-build/212/])
TAJO-605: Rename Options to KeyValueList. (jinho) (jinossy: rev
5db47466b00b7405a7decf1fbe036f4ebfb960ec)
* tajo-core/src/test/java/org/apache/tajo/engine/query/TestCTASQuery.java
* tajo-core/src/main/java/org/apache/tajo/master/session/Session.java
*
tajo-catalog/tajo-catalog-drivers/tajo-hcatalog/src/main/java/org/apache/tajo/catalog/store/HCatalogStore.java
* tajo-core/src/test/java/org/apache/tajo/TpchTestBase.java
*
tajo-catalog/tajo-catalog-server/src/main/java/org/apache/tajo/catalog/store/AbstractDBStore.java
*
tajo-core/src/test/java/org/apache/tajo/engine/planner/TestLogicalOptimizer.java
* tajo-storage/src/test/java/org/apache/tajo/storage/v2/TestStorages.java
*
tajo-core/src/main/java/org/apache/tajo/engine/planner/logical/CreateTableNode.java
* tajo-core/src/test/java/org/apache/tajo/TajoTestingCluster.java
* tajo-core/src/test/java/org/apache/tajo/engine/planner/TestPlannerUtil.java
* tajo-common/src/main/java/org/apache/tajo/util/KeyValueSet.java
* tajo-core/src/main/java/org/apache/tajo/engine/query/QueryContext.java
*
tajo-core/src/test/java/org/apache/tajo/engine/planner/physical/TestPhysicalPlanner.java
*
tajo-catalog/tajo-catalog-common/src/main/java/org/apache/tajo/catalog/DDLBuilder.java
*
tajo-catalog/tajo-catalog-common/src/main/java/org/apache/tajo/catalog/CatalogUtil.java
*
tajo-catalog/tajo-catalog-common/src/main/java/org/apache/tajo/catalog/json/TableMetaAdapter.java
* tajo-core/src/main/java/org/apache/tajo/master/querymaster/SubQuery.java
*
tajo-catalog/tajo-catalog-common/src/main/java/org/apache/tajo/catalog/TableMeta.java
* tajo-storage/src/test/java/org/apache/tajo/storage/TestMergeScanner.java
* tajo-core/src/test/java/org/apache/tajo/worker/TestRangeRetrieverHandler.java
*
tajo-catalog/tajo-catalog-common/src/main/java/org/apache/tajo/catalog/TableDesc.java
*
tajo-catalog/tajo-catalog-common/src/test/java/org/apache/tajo/catalog/TestKeyValueSet.java
* CHANGES
* tajo-core/src/main/java/org/apache/tajo/engine/planner/LogicalPlanner.java
* tajo-catalog/tajo-catalog-common/src/main/proto/CatalogProtos.proto
*
tajo-catalog/tajo-catalog-server/src/test/java/org/apache/tajo/catalog/TestCatalog.java
*
tajo-catalog/tajo-catalog-common/src/test/java/org/apache/tajo/catalog/TestOptions.java
* tajo-core/src/main/java/org/apache/tajo/master/TajoMasterClientService.java
*
tajo-core/src/main/java/org/apache/tajo/engine/planner/logical/PersistentStoreNode.java
* tajo-storage/src/main/java/org/apache/tajo/storage/StorageUtil.java
* tajo-core/src/test/java/org/apache/tajo/engine/eval/ExprTestBase.java
* tajo-core/src/test/java/org/apache/tajo/engine/query/TestNullValues.java
*
tajo-catalog/tajo-catalog-common/src/main/java/org/apache/tajo/catalog/Options.java
*
tajo-core/src/main/java/org/apache/tajo/engine/planner/global/GlobalPlanner.java
* tajo-core/src/test/java/org/apache/tajo/LocalTajoTestingUtility.java
* tajo-common/src/main/proto/PrimitiveProtos.proto
* tajo-client/src/main/java/org/apache/tajo/client/TajoClient.java
* tajo-core/src/test/java/org/apache/tajo/engine/planner/TestLogicalPlanner.java
* tajo-storage/src/test/java/org/apache/tajo/storage/TestStorages.java
*
tajo-catalog/tajo-catalog-drivers/tajo-hcatalog/src/test/java/org/apache/tajo/catalog/store/TestHCatalogStore.java
> Rename Options to KeyValueList
> ------------------------------
>
> Key: TAJO-605
> URL: https://issues.apache.org/jira/browse/TAJO-605
> Project: Tajo
> Issue Type: Task
> Reporter: Hyunsik Choi
> Assignee: Jinho Kim
> Priority: Trivial
> Labels: newbie
> Fix For: 0.9.0
>
> Attachments: TAJO-605.patch, TAJO-605_20140430_10:46:06.patch
>
>
> The name of Options class is not good for presenting its purpose. We should
> rename Options to KeyValueList. Also, it is a general purpose rather than for
> catalog. We need to move it to tajo-common.
--
This message was sent by Atlassian JIRA
(v6.2#6252)