[ 
https://issues.apache.org/jira/browse/TS-1492?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13669876#comment-13669876
 ] 

Leif Hedstrom commented on TS-1492:
-----------------------------------

James, so, looking at the code, I do agree that "backdoor" is somewhat 
unfortunate, something like "from_cop" would be better. However, the notion of 
"backdoor" is all over the code, and is bridged across API boundaries via

{code}
  na->backdoor = opt.backdoor;
{code}


My vote would be that we keep the name "backdoor" for now, and file a separate 
bug to rename this to something else. The name "allow_throttle" has some 
weirdness to it, it's somewhat the inverse of what "backdoor" means, but if you 
feel strongly about that, I don't really care that much. The "bridge" would 
then be e.g.

{code}
  na->allow_throttle = !opt.backdoor;
{code}

and we change the code in this patch to invert the logic as well.

                
> if being net_connections_throttled,  ts must to be restarted?(because of 
> can't accept health checking request)
> --------------------------------------------------------------------------------------------------------------
>
>                 Key: TS-1492
>                 URL: https://issues.apache.org/jira/browse/TS-1492
>             Project: Traffic Server
>          Issue Type: Improvement
>          Components: Core
>    Affects Versions: 3.2.0
>            Reporter: Bin Chen
>            Assignee: Leif Hedstrom
>            Priority: Critical
>              Labels: A
>             Fix For: 3.3.3
>
>         Attachments: backdoor_not_throttling.patch
>
>
> In our env, ts will be throttled because of many request incomming 
> simultaneously(because of frontend haproxy is restarted). But we don't expect 
> ts be restarted because of this case. we can handled this:
> 1、if throttled, ts's health check request always be handled
> 2、many many connection request may be handled in long time

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to