Updates:
Labels: -Type-Defect Type-Enhancement
Comment #1 on issue 175 by robhamerling: Improvements to ADC library
http://code.google.com/p/jallib/issues/detail?id=175
The following changes are planned:
- Rename adc_read() to adc_read_high_res() for naming consistency
and add a function adc_read() with deprecated warning.
- Remove const ADC_HIGH_RESOLUTION: A-D-conversion itself is always high
resolution.
Only difference between high/low resolution is a 16/8 bits return value.
- Justification is always left for low resolution, and right for high
resolution.
This is independent of which resolution the PIC supports and makes also
12-bits
resolution supported automatically (currently only 10-bits).
- Remove warning if user requests high resolution and PIC does not support
it
With adc_read_high_res() the user gets always the highest the PIC
supports, with
adc_read_low_res() he gets always 8-bits.
- Add deprecated warning to adc_read_bytes() to use adc_read_high_res() in
stead
because this low-level function is too much assembler style.
Because of these changes several procedures/functions can be simplified.
- Add const ADC_VREF_FVR to constants_jallib.jal
- Add 'standard' procedure/function headers for Jalapi documentation.
- Remove obsolete variables and comments
--
You received this message because you are subscribed to the Google Groups
"jallib" group.
To post to this group, send email to [email protected].
To unsubscribe from this group, send email to
[email protected].
For more options, visit this group at
http://groups.google.com/group/jallib?hl=en.