[ https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12713273#action_12713273 ]
Paul Elschot edited comment on LUCENE-1614 at 5/26/09 2:52 PM: --------------------------------------------------------------- I'd also prefer to have constructors with for example a List argument for the subscorers, and use an array internally. This is easily done when the parser allows postorder query construction, and all reasonable parsers can do that. When all subscorers are given in the constructor, most (or even all) of the checks on firstTime private booleans in the various scorers can be removed. One minor disadvantage of removing such firstTime booleans is that during scorer construction the index may have to be accessed because some constructors will use the next() method on their subscorers. So, when BooleanScorer2 was added, I did not like the really the add() method and firstTime booleans either, but I left them in because in that way the next() method would not be called on subscorers at construction time. Iirc I used constructor List arguments in the surround package, and that's still my preference. was (Author: paul.elsc...@xs4all.nl): I'd also prefer to have constructors with for example a List argument for the subscorers, and use an array internally. This is easily done when the parser allows postorder query construction, and all reasonable parsers can do that. When all subscorers are given in the constructor, most (or even all) of the checks on firstTime private booleans in the various scorers can be removed. One minor disadvantage of removing such firstTime booleans is that during scorer construction the index may have to be accessed because some constructors will use the next() method on their subscorers. So, when BooleanScorer2 was added, I did not like the really the add() method and firstTime booleans either, but I left them in because in that way the next() method would not be called on subscorers. Iirc I used constructor List arguments in the surround package, and that's still my preference. > Add next() and skipTo() variants to DocIdSetIterator that return the current > doc, instead of boolean > ---------------------------------------------------------------------------------------------------- > > Key: LUCENE-1614 > URL: https://issues.apache.org/jira/browse/LUCENE-1614 > Project: Lucene - Java > Issue Type: Improvement > Components: Search > Reporter: Shai Erera > Fix For: 2.9 > > Attachments: LUCENE-1614.patch, LUCENE-1614.patch, LUCENE-1614.patch > > > See > http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html > for the full discussion. The basic idea is to add variants to those two > methods that return the current doc they are at, to save successive calls to > doc(). If there are no more docs, return -1. A summary of what was discussed > so far: > # Deprecate those two methods. > # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI > (calls next() and skipTo() respectively, and will be changed to abstract in > 3.0). > #* I actually would like to propose an alternative to the names: advance() > and advance(int) - the first advances by one, the second advances to target. > # Wherever these are used, do something like '(doc = advance()) >= 0' instead > of comparing to -1 for improved performance. > I will post a patch shortly -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online. --------------------------------------------------------------------- To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org For additional commands, e-mail: java-dev-h...@lucene.apache.org