[ 
https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Shai Erera updated LUCENE-1614:
-------------------------------

    Attachment: LUCENE-1614.patch

Deprecated SpanScorer.firstTime and removed the use of it. (in general, I think 
that SpanScorer should be reviewed, since it's a public class that's documented 
that it's for inheritance), but I'm not sure all methods should be open for 
inheritance.
Also, we may want to add nextDoc and advance() to Spans. But that's a different 
issue.

I noticed I accidentally changed the signature of setFreqCurrentDoc, which is 
protected. So I reverted the change and added JustCompileSpanScorer which 
overrides that method, so we'll discover that safely in the future (test-tag 
still passes).

I also changed the documentation of docID, stating the relaxed policy (in DISI 
and CHANGES).

Besides, I've fixed all of your other comments, except for BS2 
initCountingSumScorer which I don't think we can do yet.

In general, can we do any other optimization in a different issue? This one 
already contains a lot of changes, and was opened primarily for introducing the 
new methods. We have LUCENE-1652 for further optimizations, even though we've 
covered most (or all) of them here, so perhaps we should cancel it?

> Add next() and skipTo() variants to DocIdSetIterator that return the current 
> doc, instead of boolean
> ----------------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-1614
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1614
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
>
>         Attachments: LUCENE-1614.patch, LUCENE-1614.patch, LUCENE-1614.patch, 
> LUCENE-1614.patch, LUCENE-1614.patch, LUCENE-1614.patch, LUCENE-1614.patch
>
>
> See 
> http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html
>  for the full discussion. The basic idea is to add variants to those two 
> methods that return the current doc they are at, to save successive calls to 
> doc(). If there are no more docs, return -1. A summary of what was discussed 
> so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI 
> (calls next() and skipTo() respectively, and will be changed to abstract in 
> 3.0).
> #* I actually would like to propose an alternative to the names: advance() 
> and advance(int) - the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead 
> of comparing to -1 for improved performance.
> I will post a patch shortly

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: java-dev-h...@lucene.apache.org

Reply via email to