| Instead of execution:  method() and constructor()
| Instead of withincode: withinmethod and withinconstructor
| 
| It is easier to read.
| 
| Same goes with has and hasfield.

The problem is that you're not being clear on 'within()' usage. I need to know 
about the special cases (withinmethod or withinconstructor)  rather than using 
generic within() operator.

This is not making the language easier.

So either within() should accept all expressions (type, method, constructor, 
etc) or within() should not exist at all, and you need a specific keyword for 
all possible cases. Latter leads to C++ case of operators 'dynamic_cast', 
'static_cast', 'reinterpret_cast', 'const_cast' which I don't think is a good 
idea (there was a reason people were so eager to jump from C++ to Java).

In either case, you should not have *both* generic within() operator and 
specialized operators. In this case you're encumbering the developer to 
memorize the special cases, and not helping him. So one approach should be 
chosen, rather than trying to do both.





View the original post : 
http://www.jboss.org/index.html?module=bb&op=viewtopic&p=3856324#3856324

Reply to the post : 
http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=3856324


-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. 
http://productguide.itmanagersjournal.com/
_______________________________________________
JBoss-Development mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/jboss-development

Reply via email to