Woops! Should have previewed that. Here it is again a bit more readable:

  |         CacheSPI cacheSpi = (CacheSPI) cache;
  |         CacheStoreInterceptor csi = null;
  |         int index = 0;
  | 
  |         for (Object o : cacheSpi.getInterceptorChain())
  |         {
  |             if (o instanceof CacheStoreInterceptor)
  |             {
  |                 csi = (CacheStoreInterceptor) o;
  |                 break;
  |             }
  |             index++;
  |         }
  | 
  |         cacheSpi.removeInterceptor(CacheStoreInterceptor.class);
  |         rootNode.removeChild("content");
  |         cacheSpi.addInterceptor(csi, index);
  |         rootNode.getChild("content");
  | 

View the original post : 
http://www.jboss.org/index.html?module=bb&op=viewtopic&p=4238645#4238645

Reply to the post : 
http://www.jboss.org/index.html?module=bb&op=posting&mode=reply&p=4238645
_______________________________________________
jboss-user mailing list
jboss-user@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/jboss-user

Reply via email to