Before making this an official JIRA request, I wanted to make sure that there 
wasn't already something out there that I missing.

IMO, it would be great to have an InOut annotation that can combine In and Out 
to avoid excessive typing. Examples:

Now:
@In(required=false, value="someString", scope=ScopeType.EVENT)
  | @Out(required=false, value="someString", scope=ScopeType.EVENT)
  | private String localVariableName;

Easier as:
@InOut(required=false, value="someString", scope=ScopeType.EVENT)
  | private String localVariableName;

What do you think?


View the original post : 
http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4020103#4020103

Reply to the post : 
http://www.jboss.com/index.html?module=bb&op=posting&mode=reply&p=4020103
_______________________________________________
jboss-user mailing list
jboss-user@lists.jboss.org
https://lists.jboss.org/mailman/listinfo/jboss-user

Reply via email to