m1a2st commented on PR #23094:
URL: https://github.com/apache/kafka/pull/23094#issuecomment-5248073839

   No, this is not about reusing the instance ID. The key point is that the 
first terminating push fails because it is rejected with 
`UNKNOWN_SUBSCRIPTION_ID`, since the subscription was changed on the server 
side while the client was still running.
   
   Because the terminating push failed, the client has not successfully 
terminated yet. KIP-714 explicitly allows recovery in this case: the client can 
call `GetTelemetrySubscriptions` to obtain the new subscription ID, and then 
retry `PushTelemetry(terminating=true)` with the updated ID.


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]

Reply via email to