suzhiking commented on code in PR #23486:
URL: https://github.com/apache/kafka/pull/23486#discussion_r4053530741


##########
docs/getting-started/upgrade.md:
##########
@@ -53,10 +53,11 @@ type: docs
   * Share groups now support dead-letter queue functionality as outlined in 
[KIP-1191](https://cwiki.apache.org/confluence/x/fApJFg). Any records which are 
released (beyond max delivery count) or rejected by the share consumer become 
eligible for DLQ. Share group DLQ gets enabled when the Kafka feature 
`share.version` is upgraded to 2. The user can configure a DLQ topic on a share 
group by setting the dynamic config `errors.deadletterqueue.topic.name` 
(default `""`) to the name of the DLQ topic. The cluster can be configured to 
auto create the DLQ topics by setting the dynamic cluster config 
`errors.deadletterqueue.auto.create.topics.enable` to `true` (default `false`). 
If auto create is not enabled, the user must create the DLQ topic like a 
standard Kafka topic and set the dynamic config 
`errors.deadletterqueue.group.enable` to `true` on the DLQ topic. The DLQ topic 
name must be prefixed by the value set in the dynamic cluster config 
`errors.deadletterqueue.topic.name.prefix` (defa
 ult `dlq.`). The records sent to the DLQ topic by default only contain source 
record metadata like group, topic name, partition id, offset and delivery 
count. If original record data is also required, the user must set the dynamic 
config `errors.deadletterqueue.copy.record.enable` to `true` on the share group.
   * Kafka Connect distributed workers now support the 
`internal.topics.automatic.creation.enable` configuration (default: `true`). 
When set to `false`, Connect will not automatically create internal topics 
(offset, config, status, and connector-specific offset topics) and will instead 
fail at startup if any of these topics are missing. A new 
`connect-internal-topics.sh` tool is also available for manually creating these 
topics. For further details, please refer to 
[KIP-1209](https://cwiki.apache.org/confluence/display/KAFKA/KIP-1209:+Add+configuration+to+control+internal+topic+creation+in+Kafka+Connect).
   * Streams groups now support broker-side custom task assignors, registered 
via the new broker configuration `group.streams.assignors` and selected per 
group with the new group configuration `streams.assignor.name`. For further 
details, please refer to 
[KIP-1357](https://cwiki.apache.org/confluence/x/NoSnGQ).
+  * Kafka Streams now supports static membership (`group.instance.id`) with 
the Streams Rebalance Protocol (`group.protocol=streams`). This requires 
brokers and clients running 4.4 or newer: brokers older than 4.4 reject 
`group.instance.id` on the streams group heartbeat with `INVALID_REQUEST`, 
which is a fatal error that shuts down the Kafka Streams client. Do not 
downgrade brokers below 4.4 while static members are running. For further 
details, please refer to the [Kafka Streams upgrade 
guide](/{version}/streams/upgrade-guide/).

Review Comment:
   oh thanks, corrected it now



-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]

Reply via email to