Stosh, >> Maybe these ideas suck, but here they are: >> >> execInterval() >> execTimer() >> timer() >> repeatInterval() >> execRepeat() >> >> Somebody else might be able to come up with a better name. > >Dan, >What about just calling it "execute" and swap the parameters so >that...
IMO, it should be clear from the method name what a function does. I don't think "execute" clearly indicates it repeats a function every XX milliseconds. The name "execute" I'd expect it to execute the function right away--like a closure: (function (){ alert("hello world!"); })(); At least that's what I think the name implies. Maybe the name "repeat" would suffice. -Dan