Smith, Allex wrote:
Instead I would apply a class to them like:

.boldClass {
        font-weight:700;
}

You should avoid such presentational naming. If the look of it changes next week, the class name doesn't make sense any longer and to keep it maintainable you'd have to change the class name as well.

Derive class names from the function/meaning of the elements to add additional semantic to the element. In this case for example maybe something like "product-size". This class is completely independent from its presentation.

Class names like "bold", "blue", "right" are kind of like using inline styles in the first place.


-- Klaus

Reply via email to