Josh, I've been working with your plug-in this weekend and I think it's intuitive to the user to be able to use the "delete" key to remove a wrong entry. Right now the delete key only erases the character it is over. Would it be difficult to add the logic to delete the next char in the buffer each time the delete key is pressed?
Also, I did respond in the RC2 thread about another usability change, I'd like you to consider: http://groups.google.com/group/jquery-en/browse_thread/thread/fad5c5d8b12b83c6/4b981d5f02878f59 THird, should you change the name to jquery.mask to reflect the changes you made to the plugin? Thanks, Eric On Jul 2, 8:08 pm, Josh Bush <[EMAIL PROTECTED]> wrote: > I keep coming across a few bugs here and there that need fixing. I've > released the 3rd RC for my masked input plugin. This one has breaking > changes, so if anyone is using it, please proceed carefully. > > Here's what I managed to get into this release. > > * BREAKING CHANGE: The mask function has been changed to more closely > match the style of the jQuery library. Instead of > calling .maskedinput(), you will need to call .mask(). Additionally > the .AddMaskDefinition() has been moved to a namespace and renamed. > Instead, you should make a call to .mask.addPlaceholder(). > * Fixed a bug where the buffer was wiped when text was selected and a > non-typeable character was pressed. > * Fixed a bug where the buffer was not cleared, but the text was when > pressing the escape key. > * More code cleanup. > > Please check it out athttp://digitalbush.com/projects/masked-input-plugin > > Thank You > Josh