Exactly. But we generally move over to Array{Float64} before calling OpenBLAS 
anyway, so that's not necessarily a fatal problem. Just something that needs to 
be approached with caution.

 -- John

On Jul 31, 2014, at 2:02 PM, Johan Sigfrids <johan.sigfr...@gmail.com> wrote:

> Would a Array{Nullable{Float64}} mean that you couldn't use OpenBLAS 
> algorithms on the data because the bool value is laid out interleaved with 
> the data?
> 
> On Thursday, July 31, 2014 11:16:19 PM UTC+3, John Myles White wrote:
> Array{Nullable{Float64}} is very appealing, but it's not equivalent to 
> DataArray{Float64} because of how things get stored in memory. I'd like to 
> stick with DataArray{Float64} for a while, since it makes it easier to apply 
> existing array functions. Getting rid of DataArray is very tempting, though.
> 
>  -- John
> 
> On Jul 31, 2014, at 10:37 AM, David Anthoff <ant...@berkeley.edu> wrote:
> 
>> +1 for Nullable (I have a .Net background). Data{T} seems like a very 
>> generic name for a very specific concept. For people that have not read the 
>> doc and would come across code that used this construct, the name wouldn’t 
>> give the slightest hint what this might be about, whereas something like 
>> Nullable would probably point people at least in the right direction (also, 
>> much more googleable). I’m with your dislike for the name DataArray, again I 
>> think that is a generic name that doesn’t point people to what it might 
>> mean. Maybe better to rename DataArray to something like NullableArray? I 
>> guess the really nice syntax would just be that Array{Nullable{Float64}} 
>> would end up creating the same thing as a DataArray right now, but as far as 
>> I understand the type system that wouldn’t work, right?
>>  
>> Cheers, David
>>  
>> From: julia...@googlegroups.com [mailto:ju...@googlegroups.com] On Behalf Of 
>> John Myles White
>> Sent: Thursday, July 31, 2014 10:06 AM
>> To: julia...@googlegroups.com
>> Subject: Re: [julia-users] OptionTypes.jl
>>  
>> Yeah, that's a good idea. I'd kind of like to call this something like 
>> Nullable since I'm not a huge fan of the name DataArray, but consistency is 
>> an important thing to maintain.
>>  
>>  -- John
>>  
>> On Jul 31, 2014, at 10:04 AM, Bob Nnamtrop <bob.nn...@gmail.com> wrote:
>> 
>> 
>> What about naming it the Data{T} type instead of Option{T} (or Optional{T}). 
>> Seems to fit in the DataArray{T} theme better and gives me a better idea 
>> what it is from the name (at least once one knows about DataArrays).
>> 
>> Bob
>>  
>> On Thu, Jul 31, 2014 at 10:56 AM, John Myles White <johnmyl...@gmail.com> 
>> wrote:
>> Julia, I think your naming suggestions will be more impactful if you're 
>> careful to describe your opinions in terms of your subjective preferences, 
>> rather than in terms of objective facts. Describing something as "more 
>> intuitive" isn't a very effective rhetorical strategy if others don't 
>> already share your intuitions. Rather than assert that X is more intuitive, 
>> it would be great to demonstrate why your preferred name could be more 
>> intuitive.
>>  
>> Just my two cents about effective argumentation strategies.
>>  
>>  -- John
>>  
>> On Jul 31, 2014, at 8:28 AM, Júlio Hoffimann <julio.h...@gmail.com> wrote:
>> 
>> 
>> One suggestion is to have it named as the more intuitive Optional{T}.
>> 
>> Júlio.
>> 
> 

Reply via email to