In 0.4 it is slower but this is fixed in 0.5.  So I think this style is
fine unless you need fast on 0.4 now.

On Tue, 2016-03-29 at 18:31, Evan Fields <evanjeromefie...@gmail.com> wrote:
> To keep namespaces clear and to help with code readability, I might like to
> do this:
>
> function mainFunc()
>     function helper()
>         do stuff
>         return something
>     end
>
>     call helper() and do stuff
>     return something
> end
>
> That way the helper function is only visible to the function that needs it
> and when reading the code it's obvious that the helper "belongs to" the
> main function. Is there any performance penalty for doing this? Or is this
> bad practice for some reason I don't know?

Reply via email to