I've only just started managing these switches so I don't know why flow-control 
is off & mtu not set higher.  I'm assuming mtu should be higher to allow some 
overhead on the packet.  I have noticed that there are quite a few gaint frames 
in the network.
 
Also do I need to use the me0 interface for management of the switch for access 
?
 
For a better view I've attached the configs of both switches.

Regards
Paul




 
> From: da...@appliedi.net
> To: waller...@hotmail.com; juniper-nsp@puck.nether.net
> Date: Mon, 22 Feb 2010 11:01:20 -0800
> Subject: RE: [j-nsp] (no subject)
> 
> I think your setup is configured in a workable manner (with the exclusion of 
> RVI's, but you were referring to strict switching anyway and not L3 
> termination).
> 
> The example from production I'll give uses AE (Aggregated Ethernet links, or 
> multiple ethernet links bonded together) to form the link between the two 
> switches, which then pass vlans across the switched path. You could 
> substitute this for a regular physical interface. As you see, with the 
> exception of a few choices, our configurations are similar-
> 
> 
> =====
> Switch-a
> =====
> 
> # show interfaces ae0
> description "nap-r14-pub-1 - vlan 3914 - ge/0/0/46-47";
> mtu 9216;
> aggregated-ether-options {
> link-speed 1g;
> lacp {
> active;
> }
> }
> unit 0 {
> family ethernet-switching {
> port-mode trunk;
> vlan {
> members [ 3914 3951 2102-2149 hvpubn14 hvclustmgmt2 2150-2320 2321-2349 ];
> }
> }
> }
> 
> {master:1}[edit]
> 
> =====
> Switch-b
> =====
> 
> # show interfaces ae0
> mtu 9216;
> aggregated-ether-options {
> lacp {
> active;
> }
> }
> unit 0 {
> family ethernet-switching {
> port-mode trunk;
> vlan {
> members [ 3914 3951 2102-2149 hvpubn14 hvclustmgmt2 2150-2320 2321-2349 ];
> }
> }
> }
> 
> [edit]
> 
> 
> 
> 1) establish the unit0 subinterface as a trunk port
> 2) designate the vlan membership
> 3) be sure you've done this on both sides.
> 
> I noticed in your setup you turned off flow-control. Is there a specific 
> reason you did that? We run iSCSI sans for hundreds of VPS' and we leave it 
> on (by default). Also, we run 9216 MTU for better performance on these links.
> 
> 
> Dan Farrell
> da...@appliedi.net
> 
> 
> -----Original Message-----
> From: juniper-nsp-boun...@puck.nether.net 
> [mailto:juniper-nsp-boun...@puck.nether.net] On Behalf Of Paul Waller
> Sent: Monday, February 22, 2010 5:25 AM
> To: juniper-nsp@puck.nether.net
> Subject: [j-nsp] (no subject)
> 
> 
> Hi all,
> 
> Sorry but abit of a novice when it comes to layer2 switching and Juniper 
> switches.
> 
> What I think I need to do is trunk between 2 junipers EX3200 switches, int 
> g0/0/0 connects to the router & int g0/0/1 connects to the other juniper. 1 
> switch will trunk between between the junipers & then have a trunk port to 
> the router. It is only for 2 vlans, voice & data. If anyone has a config 
> snippet on how I do this it would be appreciated.
> 
> router <-------->switch 1<-------->switch 2
> 
> My config of switch 1:
> 
> interfaces {
> ge-0/0/0 {
> apply-macro juniper-port-profile {
> Desktop;
> }
> description "Wan Router";
> mtu 1514;
> ether-options {
> auto-negotiation;
> no-flow-control;
> link-mode automatic;
> speed {
> auto-negotiation;
> }
> }
> unit 0 {
> family ethernet-switching {
> port-mode trunk;
> vlan {
> members [VOICE-VLAN DATA-VLAN];
> }
> }
> }
> }
> ge-0/0/1 {
> apply-macro juniper-port-profile {
> Desktop;
> }
> description "Connection to Juniper switch EX3200";
> mtu 1514;
> ether-options {
> auto-negotiation;
> no-flow-control;
> link-mode automatic;
> speed {
> auto-negotiation;
> }
> }
> unit 0 {
> family ethernet-switching {
> port-mode trunk;
> vlan {
> members [VOICE-VLAN DATA-VLAN];
> }
> }
> }
> }
> 
> 
> 
> Switch 2 trunk config:
> 
> ---------------------
> 
> 
> 
> 
> 
> 
> 
> ge-0/0/0 {
> apply-macro juniper-port-profile {
> Desktop;
> }
> description "Connection to Juniper switch EX3200";
> mtu 1514;
> ether-options {
> auto-negotiation;
> no-flow-control;
> link-mode automatic;
> speed {
> auto-negotiation;
> }
> }
> unit 0 {
> family ethernet-switching {
> port-mode trunk;
> vlan {
> members [VOICE-VLAN DATA-VLAN];
> }
> }
> }
> }
> 
> 
> 
> Regards
> Paul
> 
> 
> 
> 
> _________________________________________________________________
> Looking for a place to rent, share or buy? Find your next place with ninemsn 
> Property
> http://clk.atdmt.com/NMN/go/157631292/direct/01/
> _______________________________________________
> juniper-nsp mailing list juniper-nsp@puck.nether.net
> https://puck.nether.net/mailman/listinfo/juniper-nsp
> 
> 
> __________ Information from ESET NOD32 Antivirus, version of virus signature 
> database 4888 (20100222) __________
> 
> The message was checked by ESET NOD32 Antivirus.
> 
> http://www.eset.com
> 
> 
> 
> __________ Information from ESET NOD32 Antivirus, version of virus signature 
> database 4888 (20100222) __________
> 
> The message was checked by ESET NOD32 Antivirus.
> 
> http://www.eset.com
> 
                                          
_________________________________________________________________
Link all your email accounts and social updates with Hotmail. Find out now
http://windowslive.ninemsn.com.au/oneinbox?ocid=T162MSN05A0710G
interfaces {
    ge-0/0/0 {
        apply-macro juniper-port-profile {
            Desktop;
        }
        description "Wan Router";
        mtu 1514;
        ether-options {
            auto-negotiation;
            no-flow-control;
            link-mode automatic;
            speed {
                auto-negotiation;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [VOICE-VLAN DATA-VLAN];
                }
            }
        }
    }
    ge-0/0/1 {
        apply-macro juniper-port-profile {
            Desktop;
        }
        description "Layer 2 switching";
        mtu 1514;
        ether-options {
            auto-negotiation;
            no-flow-control;
            link-mode automatic;
            speed {
                auto-negotiation;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [VOICE-VLAN DATA-VLAN];
                }
            }
        }
    }
    ge-0/0/2 {
        apply-macro juniper-port-profile {
            Desktop;
        }
        description "Shoretel switch";
        mtu 1514;
        ether-options {
            auto-negotiation;
            no-flow-control;
            link-mode automatic;
            speed {
                auto-negotiation;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members VOICE-VLAN;
                }
            }
        }
    }
    ge-0/0/3 {
        apply-macro juniper-port-profile {
            Desktop;
        }
        description "Shoretel switch";
        mtu 1514;
        ether-options {
            auto-negotiation;
            no-flow-control;
            link-mode automatic;
            speed {
                auto-negotiation;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members VOICE-VLAN;
                }
            }
        }
    }
    ge-0/0/4 {
        apply-macro juniper-port-profile {
            Desktop;
        }
        description "Conf Phone";
        mtu 1514;
        ether-options {
            auto-negotiation;
            no-flow-control;
            link-mode automatic;
            speed {
                auto-negotiation;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members VOICE-VLAN;
                }
            }
        }
    }
    ge-0/0/5 {
        apply-macro juniper-port-profile {
            Desktop;
        }
        description "Conf Phone";
        mtu 1514;
        ether-options {
            auto-negotiation;
            no-flow-control;
            link-mode automatic;
            speed {
                auto-negotiation;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members VOICE-VLAN;
                }
            }
        }
    }
    ge-0/0/6 {
        apply-macro juniper-port-profile {
            Desktop;
        }
        description "Branch Server";
        mtu 1514;
        ether-options {
            auto-negotiation;
            no-flow-control;
            link-mode automatic;
            speed {
                auto-negotiation;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members DATA-VLAN;
                }
            }
        }
    }
    ge-0/0/7 {
        apply-macro juniper-port-profile {
            Desktop;
        }
        description "Branch Server";
        mtu 1514;
        ether-options {
            auto-negotiation;
            no-flow-control;
            link-mode automatic;
            speed {
                auto-negotiation;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members DATA-VLAN;
                }
            }
        }
    }
    ge-0/0/8 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members DATA-VLAN;
                }
            }
        }
    }
    ge-0/0/9 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members VOICE-VLAN;
                }
            }
        }
    }
    ge-0/0/10 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members DATA-VLAN;
                }
            }
        }
    }
protocols {
    lldp {
        interface all;
    }
    rstp {
        bridge-priority 4k;
        interface ge-0/0/0.0 {
            edge;
        }
        interface ge-0/0/1.0 {
            edge;
        }
        interface ge-0/0/2.0 {
            edge;
        }
        interface ge-0/0/3.0 {
            edge;
        }
        interface ge-0/0/4.0 {
            edge;
        }
        interface ge-0/0/5.0 {
            edge;
        interface ge-0/0/6.0 {
            edge;
        interface ge-0/0/7.0 {
            edge;
        }
    }
}
class-of-service {
    classifiers {
        dscp juniper_dscp_classifier {
            import default;
            forwarding-class voice {
                loss-priority low code-points 101110;
            }
        }
        ieee-802.1 juniper_ieee_classifier {
            import default;
            forwarding-class voice {
                loss-priority low code-points 101;
            }
        }
    }
    forwarding-classes {
        class voice queue-num 7;
        class expedited-forwarding queue-num 5;
        class assured-forwarding queue-num 1;
        class best-effort queue-num 0;
    }
    interfaces {
        ge-0/0/8 {
            scheduler-map juniper-port-profile-map;
            unit 0 {
                classifiers {
                    dscp juniper_dscp_classifier;
                    ieee-802.1 juniper_ieee_classifier;
                }
            }
        }
        ge-0/0/9 {
            scheduler-map juniper-port-profile-map;
            unit 0 {
                classifiers {
                    dscp juniper_dscp_classifier;
                    ieee-802.1 juniper_ieee_classifier;
                }
            }
        }
        ge-0/0/10 {
            scheduler-map juniper-port-profile-map;
            unit 0 {
                classifiers {
                    dscp juniper_dscp_classifier;
                    ieee-802.1 juniper_ieee_classifier;
                }
            }
        }

    scheduler-maps {
        juniper-port-profile-map {
            forwarding-class voice scheduler strict-priority-scheduler;
            forwarding-class expedited-forwarding scheduler expedited-scheduler;
            forwarding-class assured-forwarding scheduler assured-scheduler;
            forwarding-class best-effort scheduler best-effort-scheduler;
        }
    }
    schedulers {
        strict-priority-scheduler {
            transmit-rate percent 10;
            buffer-size percent 5;
            priority strict-high;
        }
        expedited-scheduler {
            transmit-rate percent 30;
            buffer-size percent 30;
            priority low;
        }
        assured-scheduler {
            transmit-rate percent 25;
            buffer-size percent 25;
            priority low;
        }
        best-effort-scheduler {
            transmit-rate percent 35;
            buffer-size percent 40;
            priority low;
        }
    }
}
ethernet-switching-options {
    voip {
        }
        interface ge-0/0/8.0 {
            vlan VOICE-VLAN;
        }
        interface ge-0/0/9.0 {
            vlan VOICE-VLAN;
        }
        interface ge-0/0/10.0 {
            vlan VOICE-VLAN;
        }
        interface ge-0/0/11.0 {
            vlan VOICE-VLAN;
        }
    inactive: secure-access-port {
        interface ge-0/0/0.0 {
            mac-limit 1;
        }
        interface ge-0/0/1.0 {
            mac-limit 1;
        }
        interface ge-0/0/2.0 {
            mac-limit 1;
        }
        interface ge-0/0/3.0 {
            mac-limit 1;
        }
        interface ge-0/0/4.0 {
            mac-limit 1;
        }
        interface ge-0/0/5.0 {
            mac-limit 1;
        }
        interface ge-0/0/6.0 {
            mac-limit 3;
        }
        interface ge-0/0/7.0 {
            mac-limit 3;
        }
        interface ge-0/0/8.0 {
            mac-limit 3;
        }
        interface ge-0/0/9.0 {
            mac-limit 3;
        }
        interface ge-0/0/10.0 {
            mac-limit 3;
        }
        interface ge-0/0/11.0 {
            mac-limit 3;
        }
        vlan DATA-VLAN {
            arp-inspection;
            examine-dhcp;
        }
        vlan VOICE-VLAN {
            arp-inspection;
            examine-dhcp;
        }
    }
}
vlans {
    DATA-VLAN {
        description "Desktop PC DATA VLAN";
        vlan-id 10;
        l3-interface vlan.1;
    }
    VOICE-VLAN {
        description "Phone VLAN";
        vlan-id 20;
        l3-interface vlan.2;
    }
    default;
}
poe {
    interface all;
}

interfaces {
    ge-0/0/0 {
        apply-macro juniper-port-profile {
            Desktop;
        }
        description "Layer 2 switching";
        mtu 1514;
        ether-options {
            auto-negotiation;
            no-flow-control;
            link-mode automatic;
            speed {
                auto-negotiation;
            }
        }
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members [VOICE-VLAN DATA-VLAN];
                }
            }
        }
    }
    ge-0/0/1 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members DATA-VLAN;
                }
            }
        }
    }
    ge-0/0/2 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members VOICE-VLAN;
                }
            }
        }
    }
    ge-0/0/3 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members DATA-VLAN;
                }
            }
        }
    }
    ge-0/0/4 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members VOICE-VLAN;
                }
            }
        }
    }
    ge-0/0/5 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members DATA-VLAN;
                }
            }
        }
    }
    ge-0/0/6 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members VOICE-VLAN;
                }
            }
        }
    }
    ge-0/0/7 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members DATA-VLAN;
                }
            }
        }
    }
    ge-0/0/8 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members VOICE-VLAN;
                }
            }
        }
    }
    ge-0/0/9 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members DATA-VLAN;
                }
            }
        }
    }
    ge-0/0/10 {
        apply-macro juniper-port-profile {
            "Desktop and Phone";
        }
        unit 0 {
            family ethernet-switching {
                port-mode access;
                vlan {
                    members VOICE-VLAN;
                }
            }
        }
    }
    me0 {
        unit 0 {
            family inet {
                address 10.11.128.3/24;
            }
        }
    }
    vlan {
        unit 1 {
            family inet {
                address 10.11.128.1/24;
            }
        }
        unit 2 {
            family inet {
                address 10.11.0.1/24;
            }
        }
    }  
}
protocols {
    lldp {
        interface all;
    }
    rstp {
        bridge-priority 4k;
        interface ge-0/0/0.0 {
            edge;
         }
    }
}
vlans {
    DATA-VLAN {
        description "Desktop PC DATA VLAN";
        vlan-id 10;
        l3-interface vlan.1;
    }
    VOICE-VLAN {
        description "Phone VLAN";
        vlan-id 20;
        l3-interface vlan.2;
    }
    default;
}
poe {
    interface all;
}

_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp

Reply via email to