2 things:
1/ add "family ccc" under ge-1/2/0.2
2/ add "encapsulation ethernet" under l2circuit neighbor config.
Default encaps when You use tagged units is "ethernet-vlan" and with "ethernet-vlan" the L2circuit actually checks if VLAN ids are same on both ends. With "encapsulation ethernet" this check is not done.
HTH
Thanks
Alex

----- Original Message ----- From: "Eric Van Tol" <e...@atlantech.net>
To: <juniper-nsp@puck.nether.net>
Sent: Wednesday, March 13, 2013 11:27 AM
Subject: [j-nsp] VLAN bundles in CCC


Greetings everyone,
I'm trying to configure a list of VLANs on an interface and include them in a CCC to cross-connect them between back-to-back routers and it's not working. I've tried several variations of what I believe is supposed to work, but no success. Here's my topology:

Switch-A <==> Router-A <==> Router-B <==> Switch-B

VLAN1 from both switches to their upstream router is configured as an SVI for basic switch connectivity. VLANs 10, 20, 30, 40, 50, and 60 are supposed to be "bundled" and transported across a single interface that connects Router-A and Router-B. I'm able to do this one VLAN at a time (ie. one VLAN per logical unit) just fine, but I can't get a bundle to work. I've followed the guidelines here:

http://tinyurl.com/abw64ua

but it's not working for me. Maybe I'm misunderstanding how the VLAN bundle is supposed to be handed off to me? I see that my l2circuit is up, but no traffic passes between nodes configured on VLAN 10. I've tried both the 'l2circuit' and 'connections' type of CCC. I'm on an MX80 running 11.4.

Config of Router-A follows (the other is exactly the same, except the IP addresses).

interfaces {
   ge-1/2/0 {
   description Switch-A;
   flexible-vlan-tagging;
   encapsulation flexible-ethernet-services;
       unit 1 {
           vlan-id 1;
           family inet {
               address 192.168.1.1/30;
           }
       }
       unit 2 {
           encapsulation vlan-ccc;
           vlan-id-list [ 10 20 30 40 50 60 ];
       }
   }
}
ge-1/2/1 {
   description Router-B;
   flexible-vlan-tagging;
   encapsulation flexible-ethernet-services;
   unit 1 {
       vlan-id 1;
       family inet {
           address 10.10.0.1/30;
       }
       family iso;
       family mpls;
   }
}
lo0 {
   unit 0 {
       family inet {
           address 10.0.0.1/32;
       }
       family iso {
           address 47.0001.0100.1000.0001.00;
       }
   }
}
protocols {
   mpls {
   interface ge-1/2/0.2;
       interface ge-1/2/1.1;
   }
   isis {
       interface ge-1/2/1.1;
       interface lo0.0 {
           passive;
       }
   }
   ldp {
       interface ge-1/2/1.1;
       interface lo0.0;
   }
   l2circuit {
       neighbor 10.0.0.2 {
           interface ge-1/2/0.2 {
               virtual-circuit-id 2;
               no-control-word;
           }
       }
   }
}

Thanks,
evt


_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp


_______________________________________________
juniper-nsp mailing list juniper-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/juniper-nsp

Reply via email to