https://bugs.kde.org/show_bug.cgi?id=375543

            Bug ID: 375543
           Summary: Rename variable helper does not work in a few
                    situations
           Product: kdevelop
           Version: 5.1.0
          Platform: Appimage
                OS: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: Language Support: CPP (Clang-based)
          Assignee: kdevelop-bugs-n...@kde.org
          Reporter: master.ha...@gmail.com
  Target Milestone: ---

The rename variable helper has a few situations where it does not work
correctly:

1. if you rename a variable that has places highlighted for incorrect syntax,
the variable name will not be updated on those lines.
e.g.
int foo()
{
  int bar;
  bar.isValid();
  //changing the name of bar will not update the name of bar in the second
line, because there is a syntax error
}
2. renaming a variable after changing the length of the line UP to the variable
name will cause variable name replacements to have extra text added to them
other than just the new variable name (sometimes including a few characters
after the variable name from the line that changed)

e.g.
int foo()
{
 int bar=276;
 bar=3;
}
changing bar to a QString and then renaming it will often lead to something
like this:
QString renamed=276;
renamed=273;

-- 
You are receiving this mail because:
You are watching all bug changes.

Reply via email to