https://bugs.kde.org/show_bug.cgi?id=523207

            Bug ID: 523207
           Summary: GPU sensors are missing from the Add Sensor(Thermal
                    Sensor) dialog when the GPU name contains brackets
    Classification: Plasma
           Product: plasma-integration
      Version First unspecified
       Reported In:
          Platform: Other
                OS: Linux
            Status: REPORTED
          Severity: normal
          Priority: NOR
         Component: general
          Assignee: [email protected]
          Reporter: [email protected]
  Target Milestone: ---

## Environment
- Thermal Monitor 0.2.7
- Plasma 6.7.2 / ksystemstats 6.7.2 (Arch/CachyOS)
- AMD Radeon RX 9070 XT (also reproducible with RX 7900 series)

## Bug 1: GPU sensors filtered out of the Add Sensor list

ksystemstats reports GPU sensor display names taken from the PCI ID database,
which contain square brackets, e.g.:

    Navi 48 [Radeon RX 9070/9070 XT/9070 GRE] (Navi 48 XTX [Sapphire Pulse
Radeon RX 9070 XT]) junction (°C)

The filter in `contents/ui/config/AvailableSensors.qml` rejects any row whose
display string contains `[` (intended to remove group rows):

    return sensorId.length > 0 && display.includes("(°C)") &&
!display.includes("[");

As a result, all temperature sensors of such GPUs are silently missing from the
Add Sensor dialog. Suggested fix — only reject names that *start* with a
bracket:

    return sensorId.length > 0 && display.includes("(°C)") &&
!display.startsWith("[");

## Bug 2: Long sensor names push the add button out of the dialog

Once the GPU sensors appear, their long names make the rows wider than the
dialog: the label in `AddSensorDialog.qml` sets `elide: Text.ElideRight` but
has
no `Layout.fillWidth`, so inside the `RowLayout` it takes its full implicit
width and pushes the add/undo `ToolButton` outside the visible area, making the
sensor impossible to add. The dialog is not resizable.

Suggested fix: give the label `Layout.fillWidth: true` (and drop the filler
`Item`), so the name elides and the button stays visible. Optionally also strip
the parenthesized subsystem part from GPU names for readability.

Both fixes tested locally against 0.2.7.

-- 
You are receiving this mail because:
You are watching all bug changes.

Reply via email to