https://bugs.kde.org/show_bug.cgi?id=525531
Bug ID: 525531
Summary: Unable to access SMB shares via DFS links
Classification: Frameworks and Libraries
Product: kio-extras
Version First unspecified
Reported In:
Platform: Arch Linux
OS: Linux
Status: REPORTED
Severity: normal
Priority: NOR
Component: Samba
Assignee: [email protected]
Reporter: [email protected]
CC: [email protected]
Target Milestone: ---
Created attachment 195994
--> https://bugs.kde.org/attachment.cgi?id=195994&action=edit
kio.smb and libsmbclient debug log
DESCRIPTION
I'm trying to access SMB shares via our corporate DFS server structure using
Dolphin; while navigating the DFS structure works correctly, Dolphin fails to
enter SMB share through the DFS link. Accessing the same share directly,
without DFS, works fine.
Server side is running Windows Server 2019/2022, but the issue seems local.
Attached is the debug log for kio.smb AND libsmbclient, that shows the issue.
While accessing DFS server for the first time, things seem to work as expected
- authentication is done via the already issued kerberos ticket:
cli_session_setup_spnego_send: Connect to domain01.local as
[email protected] using SPNEGO
However, when trying to enter actual share it seems to try to authenticate
using a local user name:
[...]
negotiated dialect[SMB3_11] against server[DFS01.DOMAIN01.LOCAL]
cli_session_setup_spnego_send: Connect to DFS01.DOMAIN01.LOCAL as
localuser@WORKGROUP using SPNEGO
Starting GENSEC mechanism spnego
Starting GENSEC submechanism gse_krb5
gensec_gse_client_start: Not using kerberos to cifs/DFS01.DOMAIN01.LOCAL as
WORKGROUP\localuser: NT_STATUS_INVALID_PARAMETER
[...]
... which of course doesn't work.
Operating System: Arch Linux
KDE Plasma Version: 6.7.5
KDE Frameworks Version: 6.30.0
Qt Version: 6.11.2
Kernel Version: 7.2.3-arch1-3 (64-bit)
/usr/lib/libsmbclient.so.0.8.1 is owned by smbclient 2:4.24.7-1
--
You are receiving this mail because:
You are watching all bug changes.