https://bugs.kde.org/show_bug.cgi?id=525880

            Bug ID: 525880
           Summary: Partitionmanager not removing fstab partition entries
                    with the same mount point leads to OS not booting up
    Classification: Applications
           Product: partitionmanager
      Version First unspecified
       Reported In:
          Platform: Fedora RPMs
                OS: Linux
            Status: REPORTED
          Severity: major
          Priority: NOR
         Component: general
          Assignee: [email protected]
          Reporter: [email protected]
  Target Milestone: ---

DESCRIPTION
If Partitionmanager is used to mount partitions to certain directories (e.g.
/home), it won't remove (or comment out) any other partition, or at least
sub-volume, with the same mount point from the fstab file; leading to boot
failures upon restart.

STEPS TO REPRODUCE
1. In Partitionmanager, right-click a partition and edit its mount point;
mounting it to /home.
2. When done, right-click the partition again and click on mount.
3. Restart the computer.

OBSERVED RESULT
The computer fails to boot properly. Inspecting the fstab file reveals that if
a btrfs sub-volume has had the same mount point as the newly mounted partition
(this is the default in fedora), it doesn't get removed, or preferably
commented out from the fstab file; leading to 2 "partitions" having the same
/home mountpoint.

EXPECTED RESULT
Upon mounting a new partition to a directory, Partitionmanager should remove,
or preferably comment out any other fstab entries with the same mount-point.

SOFTWARE/OS VERSIONS
Operating System: Fedora 44
KDE Plasma Version: 6.7

-- 
You are receiving this mail because:
You are watching all bug changes.

Reply via email to