https://bugs.kde.org/show_bug.cgi?id=390698

--- Comment #22 from Fredrik Höglund <fred...@kde.org> ---
(In reply to Vlad Zagorodniy from comment #16)
> Fredrik, what do you mean by "a complex transformation"?

Any transformation that does not just translate and/or scale the window.
Although scaling can also benefit from this, so I guess any transformation that
does not just translate the window.

Some comments on the branch:

There is no need to call unbind() before deleting an object - deleting an
object also unbinds it from any bind points it is bound to in the current
context.

[libkwineffects] simplify GLRenderTarget:

Please split this commit so each change is done as a separate commit. It makes
the changes easier to review.

I think finalPrePaintScreen() should create the render buffer and render target
on-demand, and also destroy them when PAINT_SCREEN_MULTISAMPLE is not set. They
consume a lot of memory, so we don't want to keep them around when they are not
being used.

I would rename m_multisamplingCtx to m_multisampling. Ctx suggests that it's a
GL context.

The changes look pretty good otherwise!

-- 
You are receiving this mail because:
You are watching all bug changes.

Reply via email to