https://bugs.kde.org/show_bug.cgi?id=490909

--- Comment #4 from Nate Graham <n...@kde.org> ---
I can't figure out a clean way to fix this for Kickoff. Giving up for now.

If anyone wants to take over, the diff that will fix this for everything except
Kickoff is:

> diff --git applets/kicker/plugin/appentry.cpp 
> applets/kicker/plugin/appentry.cpp
> index 135d7fd895..940915fe48 100644
> --- applets/kicker/plugin/appentry.cpp
> +++ applets/kicker/plugin/appentry.cpp
> @@ -346,9 +346,10 @@ QString AppEntry::nameFromService(const KService::Ptr 
> &service, NameFormat nameF
>  {
>      const QString &name = service->name();
>      QString genericName = service->genericName();
> +    QString comment = service->comment();
>  
>      if (genericName.isEmpty()) {
> -        genericName = service->comment();
> +        genericName = comment;
>      }
>  
>      if (nameFormat == NameOnly || genericName.isEmpty() || name == 
> genericName) {
> @@ -356,7 +357,10 @@ QString AppEntry::nameFromService(const KService::Ptr 
> &service, NameFormat nameF
>      } else if (nameFormat == GenericNameOnly) {
>          return genericName;
>      } else if (nameFormat == NameAndGenericName) {
> -        return i18nc("App name (Generic name)", "%1 (%2)", name, 
> genericName);
> +        if (comment.isEmpty()) {
> +            comment = genericName;
> +        }
> +        return i18nc("App name (Comment or Generic name)", "%1 (%2)", name, 
> comment);
>      } else {
>          return i18nc("Generic name (App name)", "%1 (%2)", genericName, 
> name);
>      }

-- 
You are receiving this mail because:
You are watching all bug changes.

Reply via email to