bruns added a comment.

  I think it would be better to not change behaviour for any backend, but just 
default label() to description() everywhere.
  
  Then in the next step, adjust description() and label() for each backend, 
shorten label where possible, and extend description() so it becomes more 
informative.

INLINE COMMENTS

> fstabdevice.cpp:146
> +    if (m_storageAccess->isAccessible()) {
> +        return m_storageAccess->filePath();
> +    } else {

filePath in most cases does not depend on isAccessible ... it would be annoying 
if the label changed everytime the device is mounted.

> udisksdevice.cpp:234
>  {
>      const QString hintName = property("HintName").toString(); // non-cached
>      if (!hintName.isEmpty()) {

This would be the correct value only for label() now, no longer for the 
description (which should be more verbose).

REPOSITORY
  R245 Solid

REVISION DETAIL
  https://phabricator.kde.org/D28590

To: meven, #frameworks, bruns, sitter
Cc: kde-frameworks-devel, LeGast00n, cblack, GB_2, michaelh, ngraham, bruns

Reply via email to