davidedmundson added a comment.

  Offtopic, but in future can you adjust the summary when rewriting a patch 
rather than leaving a comment, it's easier to read. Phab still keeps the 
history if we need it.
  
  So this is for fixing when we have a mainItem whose size is bigger/smaller 
than its own size hints? 
  We resize the main itemin updateLayoutParams() but we've already resized the 
window by then.
  
  If I've understood that correctly, that makes sense, and this is an 
improvement.
  
  but: we're still doing a resize whislt we have the old window management 
min/max hints set from the previous item, so it'll still have an extra resize, 
just at a kwin level not here.

INLINE COMMENTS

> dialog.cpp:301-306
>              if (mainItem) {
>                  syncToMainItemSize();
>              }
>              if (mainItemLayout) {
>                  updateLayoutParameters();
>              }

>From what I can tell, you're basically trying to put the code from 
>updateLayoutParameters in to synctoMainItemSize which is fine, but then we 
>shouldn't end up calling both.

REPOSITORY
  R242 Plasma Framework (Library)

REVISION DETAIL
  https://phabricator.kde.org/D5912

To: mart, #plasma, hein, davidedmundson
Cc: broulik, davidedmundson, plasma-devel, #frameworks, ZrenBot, spstarr, 
progwolff, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, mart, 
lukas

Reply via email to