broulik added inline comments. INLINE COMMENTS
> engine.cpp:536 > + connect(l, &ImageLoader::signalError, this, [=]() { > + qCDebug(KNEWSTUFFCORE) << "ERROR preview: " << entry.name() << type; > + --m_numPictureJobs; You're copying `entry` into the lambda just for a debug. > imageloader_p.h:59 > Q_SIGNALS: > + void signalError(ImageLoader *); > void signalPreviewLoaded(const KNSCore::EntryInternal &, > KNSCore::EntryInternal::PreviewType); Why have this argument if you're not naming it and not using it? REPOSITORY R304 KNewStuff REVISION DETAIL https://phabricator.kde.org/D8811 To: anthonyfieroni, leinir, dfaure Cc: broulik, #frameworks, ZrenBot