dfaure accepted this revision.
dfaure added inline comments.
This revision is now accepted and ready to land.

INLINE COMMENTS

> legacycodec.cpp:118
> +                    bool nonCharacter;
> +                    if (!(nonCharacter = QChar::isNonCharacter(uc)) && uc > 
> 0xffff && uc < 0x110000) {
> +                        // surrogate pair

[it would be so much more readable to move the assignment to the previous 
line...]

> legacycodec.h:21
> +#ifndef LEGACY_CODEC_H
> +#define LEGACY_CODEC_H 1
> +

this "1" here is unusual :-)

> legacycodec.h:36
> +        setCodecForLocale(nullptr);
> +    };
> +

remove the extra ';', some compilers warn about that.

REPOSITORY
  R241 KIO

REVISION DETAIL
  https://phabricator.kde.org/D18161

To: cfeck, #frameworks, #dolphin, dfaure
Cc: frispete, nathanshearer, nerdopolist, ngraham, kde-frameworks-devel, 
michaelh, bruns

Reply via email to