*** This bug is a duplicate of bug 1548009 ***
https://bugs.launchpad.net/bugs/1548009
** This bug has been marked a duplicate of bug 1548009
ZFS pools should be automatically scrubbed
--
You received this bug notification because you are a member of Kernel
Packages, which is subscribed to zfs-linux in Ubuntu.
https://bugs.launchpad.net/bugs/1600579
Title:
zfsutils-linux scrub cron job fails
Status in zfs-linux package in Ubuntu:
New
Bug description:
The cron job for zfsutils-linux fails to run. The problem is that
$PATH (on xenial, at least) is set to /bin:/usr/bin. The zpool binary
is in /sbin and the /usr/lib/zfs-linux/scrub script (below) doesn't
give the full path or modify $PATH. Further, the 2>&1 ensures that the
useful error is sent to awk and not stderr where it'd be more easily
noticed.
The fix is to just s,zpool,/sbin/zpool, in the script. And probably
remove the stderr redirection, since I'm not sure if it's actually
useful here.
This is the script as it currently is, for reference:
#!/bin/sh -eu
# Scrub all healthy pools.
zpool list -H -o health,name 2>&1 | \
awk 'BEGIN {FS="\t"} {if ($1 ~ /^ONLINE/) print $2}' | \
while read pool
do
zpool scrub "$pool"
done
To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/zfs-linux/+bug/1600579/+subscriptions
--
Mailing list: https://launchpad.net/~kernel-packages
Post to : [email protected]
Unsubscribe : https://launchpad.net/~kernel-packages
More help : https://help.launchpad.net/ListHelp