https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29392

--- Comment #14 from Julian Maurice <[email protected]> ---
Looking again, I think there are several solutions:

1) Keep the patch as is and add the hook in the merge API endpoint
   Pros: it works as intended, allowing record modification before it's saved
   Cons: it duplicates code

2) Move the hook at the end Koha::Biblio::merge_with and rename the hook to
"after_biblio_action"
   Pros: Does not duplicate code
   Cons: Forces to re-fetch and re-save biblio record, triggering
'before_biblio_action/save' twice per merge operation

3) Pass $record and $framework to ->merge_with, and call ModBiblio from there
   Pros: It can be called during the DB transaction, so an error later in the
process cancels the whole merge operation. No duplicated code. The hook can
work as intended.
   Cons: None ? I can't find any but maybe there is a reason it wasn't done
like that in bug 33036.

Martin, what do you think about 3 ?

-- 
You are receiving this mail because:
You are watching all bug changes.
_______________________________________________
Koha-bugs mailing list -- [email protected]
To unsubscribe send an email to [email protected]
website : http://www.koha-community.org/
git : http://git.koha-community.org/
bugs : http://bugs.koha-community.org/

Reply via email to