On Tue, 2008-03-11 at 23:50 -0500, Jerone Young wrote:
> diff --git a/qemu/sysemu.h b/qemu/sysemu.h
> --- a/qemu/sysemu.h
> +++ b/qemu/sysemu.h
> @@ -182,6 +182,9 @@ int load_elf(const char *filename, int64
>               uint64_t *pentry, uint64_t *lowaddr, uint64_t *highaddr);
>  int load_aout(const char *filename, uint8_t *addr);
>  int load_uboot(const char *filename, target_ulong *ep, int *is_linux);
> +int load_uboot_l(const char *filename, target_ulong *ep, 
> +             target_ulong *la, target_ulong *loaded_image_size,
> +             int *is_linux);
>  #endif
> 
>  #ifdef HAS_AUDIO

I don't like the "_l" name, nor "la". Without reading the code I have no
idea what those mean.

Can't you just update the other load_uboot() callers? There are only 4
of them... and while you're at it, you should rename the function to
load_uimage(). Pass NULL for whatever you rename "la" to, just like
"is_linux" is handled already.

-- 
Hollis Blanchard
IBM Linux Technology Center


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
kvm-devel mailing list
kvm-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/kvm-devel

Reply via email to