On 29.03.2013, at 04:08, Bhushan Bharat-R65777 wrote:

> 
> 
>> -----Original Message-----
>> From: Alexander Graf [mailto:ag...@suse.de]
>> Sent: Friday, March 29, 2013 7:26 AM
>> To: Bhushan Bharat-R65777
>> Cc: kvm-ppc@vger.kernel.org; k...@vger.kernel.org; Wood Scott-B07421; Bhushan
>> Bharat-R65777
>> Subject: Re: [PATCH 2/4 v2] KVM: PPC: debug stub interface parameter defined
>> 
>> 
>> On 21.03.2013, at 07:24, Bharat Bhushan wrote:
>> 
>>> From: Bharat Bhushan <bharat.bhus...@freescale.com>
>>> 
>>> This patch defines the interface parameter for KVM_SET_GUEST_DEBUG
>>> ioctl support. Follow up patches will use this for setting up hardware
>>> breakpoints, watchpoints and software breakpoints.
>>> 
>>> Also kvm_arch_vcpu_ioctl_set_guest_debug() is brought one level below.
>>> This is because I am not sure what is required for book3s. So this
>>> ioctl behaviour will not change for book3s.
>>> 
>>> Signed-off-by: Bharat Bhushan <bharat.bhus...@freescale.com>
>>> ---
>>> v2:
>>> - No Change
>>> 
>>> arch/powerpc/include/uapi/asm/kvm.h |   23 +++++++++++++++++++++++
>>> arch/powerpc/kvm/book3s.c           |    6 ++++++
>>> arch/powerpc/kvm/booke.c            |    6 ++++++
>>> arch/powerpc/kvm/powerpc.c          |    6 ------
>>> 4 files changed, 35 insertions(+), 6 deletions(-)
>>> 
>>> diff --git a/arch/powerpc/include/uapi/asm/kvm.h
>>> b/arch/powerpc/include/uapi/asm/kvm.h
>>> index c2ff99c..15f9a00 100644
>>> --- a/arch/powerpc/include/uapi/asm/kvm.h
>>> +++ b/arch/powerpc/include/uapi/asm/kvm.h
>>> @@ -272,8 +272,31 @@ struct kvm_debug_exit_arch {
>>> 
>>> /* for KVM_SET_GUEST_DEBUG */
>>> struct kvm_guest_debug_arch {
>>> +   struct {
>>> +           /* H/W breakpoint/watchpoint address */
>>> +           __u64 addr;
>>> +           /*
>>> +            * Type denotes h/w breakpoint, read watchpoint, write
>>> +            * watchpoint or watchpoint (both read and write).
>>> +            */
>>> +#define KVMPPC_DEBUG_NOTYPE                0x0
>>> +#define KVMPPC_DEBUG_BREAKPOINT            (1UL << 1)
>>> +#define KVMPPC_DEBUG_WATCH_WRITE   (1UL << 2)
>>> +#define KVMPPC_DEBUG_WATCH_READ            (1UL << 3)
>> 
>> Are you sure you want to introduce these here, just to remove them again in a
>> later patch?
> 
> Up to this patch the scope was limited to this structure. So for clarity I 
> defined here and later the scope expands so moved out of this structure. I do 
> not think this really matters, let me know how you want to see ?

Well, at least I want to see the names be identical between the patches ;).


Alex

--
To unsubscribe from this list: send the line "unsubscribe kvm-ppc" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to