On Tuesday 29 July 2008 00:26:25 Ben-Ami Yassour wrote:
> FROM: Avi Kivity <[EMAIL PROTECTED]>
>
> This can be used by kvm subsystems that are interested in when
> interrupts
> are acked, for example time drift compenstation.
>
> [Ben: add notification call to the pic and ioapic]
>
> Signed-off-by: Avi Kivity <[EMAIL PROTECTED]>
> Signed-off-by: Ben-Ami Yassour <[EMAIL PROTECTED]>
> ---
>  arch/x86/kvm/i8259.c       |    1 +
>  arch/x86/kvm/irq.c         |   22 ++++++++++++++++++++++
>  arch/x86/kvm/irq.h         |    5 +++++
>  include/asm-x86/kvm_host.h |    7 +++++++
>  virt/kvm/ioapic.c          |    2 ++
>  5 files changed, 37 insertions(+), 0 deletions(-)
>
> diff --git a/arch/x86/kvm/i8259.c b/arch/x86/kvm/i8259.c
> index 55e179a..d2a61bf 100644
> --- a/arch/x86/kvm/i8259.c
> +++ b/arch/x86/kvm/i8259.c
> @@ -186,6 +186,7 @@ int kvm_pic_read_irq(struct kvm_pic *s)
>               irq = 7;
>               intno = s->pics[0].irq_base + irq;
>       }
> +     kvm_notify_acked_irq(s->irq_request_opaque, irq);

It's not what I mean, sorry to not tell it clearly... Now it got 
confusing semantic.

irq_request_opaque has nothing to do with acked_irq. What I mean is 
rename irq_request_opaque to struct* kvm in struct kvm_pic, and 
modify all irq_request() calling(three of them in all) with (void 
*)kvm.

It's not a must, I just think it's clearer...

--
regards
Yang, Sheng

--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to