Amit Shah wrote:
* On Friday 22 Aug 2008 23:48:42 Avi Kivity wrote:
Amit Shah wrote:
diff --git a/include/linux/kvm.h b/include/linux/kvm.h
index d9ef7d3..2956e35 100644
--- a/include/linux/kvm.h
+++ b/include/linux/kvm.h
@@ -495,4 +495,6 @@ struct kvm_assigned_irq {
        __u32 flags;
 };

+#define KVM_DEV_ASSIGN_USE_VTD (1 << 1)
+
 #endif
(1 >> 0)?

I kept the 1st field reserved for no particular implementation in mind as of now.


Why?

This is a userspace inteface, so use a generic name like iommu.  We also
need a KVM_CAP so userspace can check whether an iommu is present or not.

We could have multiple hardware IOMMU implementations, like Intel's VT-d and AMD's IOMMU.


Not in userspace. Userspace sees either iommu or no iommu; it doesn't care about the iommu model.

Also, is KVM_CAP_foo needed for this? This is the only #define that'll be used and we can simply do something like

#ifdef KVM_DEV_ASSIGN_USE_VTD
flags |= KVM_DEV_ASSIGN_USE_VTD
#endif

?

That only detects if the headers have the flag, not if the kernel actually supports it (and whether there is an iommu in the host). We need run-time detection.

--
I have a truly marvellous patch that fixes the bug which this
signature is too narrow to contain.

--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to