On 08/24/2010 03:16 PM, Chen Cao wrote:
On Tue, Aug 24, 2010 at 03:04:44PM +0300, Avi Kivity wrote:
  On 08/24/2010 03:07 PM, Isaku Yamahata wrote:
On Tue, Aug 24, 2010 at 02:42:18PM +0300, Avi Kivity wrote:
  On 08/24/2010 02:35 PM, Isaku Yamahata wrote:
Add Cc: m...@redhat.com.

MAX_PCI_SLOTS should be in pci.h instead of qdev.h?
And the name should be start with PCI_ prefix for consistency?

Except that, the patches look okay.

These aren't slots, are they?  They are functions.
The function checks if given $slot.$fn (or $slot) is valid.
So it's slots. max 32.
+    assert(devfn<   PCIBUS_MAX_DEVICES);


Looks like we're comparing a function number to PCIBUS_MAX_DEVICES.

PCIBUS_MAX_DEVICES is the size of PCIBus.devices[], I have added it in
the first patch at the defination of struct PCIBus, line 50 hw/pci.c.
so i think the better name of the macro should be PCIBUS_MAX_FN,
right?

Or make it 32 and scale it by PCI_FUNCTIONS_PER_DEVICE.

PCIBus.devices[] should be renamed to functions[] (later).

--
error compiling committee.c: too many arguments to function

--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to