(2011/12/16 19:15), Xiao Guangrong wrote:

-static void mmu_page_add_parent_pte(struct kvm_vcpu *vcpu,
-                                   struct kvm_mmu_page *sp, u64 *parent_pte)
+static void mmu_page_add_set_parent_pte(struct kvm_vcpu *vcpu,
+                                       struct kvm_mmu_page *sp,
+                                       u64 *parent_pte)
  {
        if (!parent_pte)
                return;

+       mmu_spte_set(parent_pte, __pa(sp->spt) | SHADOW_PAGE_TABLE);
        pte_list_add(vcpu, parent_pte,&sp->parent_ptes);
  }

There are a few prefixes in the kvm mmu code.

        e.g. mmu_page_, kvm_mmu_, kvm_mmu_page_, ...

Sometimes we also use "sp".

How about deciding a consistent way from now on?

E.g.
        if the function is static and for local use only, such a prefix
        can be eliminated,

        if it is used outside of mmu.c, kvm_mmu_ is needed,

        we use sp for kvm_mmu_page,
        ...

(just an example)

        Takuya
--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to