On 19.01.2012, at 10:31, Paul Mackerras wrote:

> On Thu, Jan 19, 2012 at 12:17:38AM +0100, Alexander Graf wrote:
> 
>>      /* Allocate guest's hashed page table */
>> +
>> +    /* using preallocated memory */
>> +    li = kvm_alloc_hpt();
>> +    if (li) {
>> +            hpt = (ulong)li->base_virt;
>> +            kvm->arch.hpt_li = li;
>> +            goto has_hpt;
>> +    }
>> +
>> +    /* using dynamic memory */
>>      hpt = __get_free_pages(GFP_KERNEL|__GFP_ZERO|__GFP_REPEAT|__GFP_NOWARN,
>>                             HPT_ORDER - PAGE_SHIFT);
>> +
>> +has_hpt:
> 
> This would look cleaner and be easier to follow if you used the "else"
> keyword. :)

Yeah, I just figured we might want to extend the "else" path by quite a bit. 
But I'll change it for now :). It certainly does look better when done that way 
in its current form.


Alex

--
To unsubscribe from this list: send the line "unsubscribe kvm" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to