On Wed, 18 Dec 2019 13:55:15 -0800
Sean Christopherson <sean.j.christopher...@intel.com> wrote:

> Now that all architectures tightly couple vcpu allocation/free with the
> mandatory calls to kvm_{un}init_vcpu(), move the sequences verbatim to
> common KVM code.
> 
> Move both allocation and initialization in a single patch to eliminate
> thrash in arch specific code.  The bisection benefits of moving the two
> pieces in separate patches is marginal at best, whereas the odds of
> introducing a transient arch specific bug are non-zero.
> 
> Acked-by: Christoffer Dall <christoffer.d...@arm.com>
> Signed-off-by: Sean Christopherson <sean.j.christopher...@intel.com>
> ---
>  arch/mips/kvm/mips.c       | 33 ++++++---------------------------
>  arch/powerpc/kvm/powerpc.c | 27 ++++-----------------------
>  arch/s390/kvm/kvm-s390.c   | 31 +++++--------------------------
>  arch/x86/kvm/x86.c         | 28 ++--------------------------
>  include/linux/kvm_host.h   |  2 +-
>  virt/kvm/arm/arm.c         | 29 ++---------------------------
>  virt/kvm/kvm_main.c        | 21 ++++++++++++++++++---
>  7 files changed, 38 insertions(+), 133 deletions(-)

(...)

> diff --git a/arch/s390/kvm/kvm-s390.c b/arch/s390/kvm/kvm-s390.c
> index 8543d338a06a..2ed76584ebd9 100644
> --- a/arch/s390/kvm/kvm-s390.c
> +++ b/arch/s390/kvm/kvm-s390.c
> @@ -2530,9 +2530,6 @@ void kvm_arch_vcpu_destroy(struct kvm_vcpu *vcpu)
>       if (vcpu->kvm->arch.use_cmma)
>               kvm_s390_vcpu_unsetup_cmma(vcpu);
>       free_page((unsigned long)(vcpu->arch.sie_block));
> -
> -     kvm_vcpu_uninit(vcpu);
> -     kmem_cache_free(kvm_vcpu_cache, vcpu);
>  }
>  
>  static void kvm_free_vcpus(struct kvm *kvm)
> @@ -3014,29 +3011,15 @@ int kvm_arch_vcpu_precreate(struct kvm *kvm, unsigned 
> int id)
>       return 0;
>  }
>  
> -struct kvm_vcpu *kvm_arch_vcpu_create(struct kvm *kvm,
> -                                   unsigned int id)
> +int kvm_arch_vcpu_create(struct kvm_vcpu *vcpu)
>  {
> -     struct kvm_vcpu *vcpu;
>       struct sie_page *sie_page;
>       int rc;
>  
> -     rc = -ENOMEM;
> -
> -     vcpu = kmem_cache_zalloc(kvm_vcpu_cache, GFP_KERNEL);
> -     if (!vcpu)
> -             goto out;
> -
> -     rc = kvm_vcpu_init(vcpu, kvm, id);
> -     if (rc)
> -             goto out_free_cpu;
> -
> -     rc = -ENOMEM;
> -
>       BUILD_BUG_ON(sizeof(struct sie_page) != 4096);
>       sie_page = (struct sie_page *) get_zeroed_page(GFP_KERNEL);
>       if (!sie_page)
> -             goto out_uninit_vcpu;
> +             return -ENOMEM;
>  
>       vcpu->arch.sie_block = &sie_page->sie_block;
>       vcpu->arch.sie_block->itdba = (unsigned long) &sie_page->itdb;
> @@ -3087,15 +3070,11 @@ struct kvm_vcpu *kvm_arch_vcpu_create(struct kvm *kvm,
>                vcpu->arch.sie_block);
>       trace_kvm_s390_create_vcpu(id, vcpu, vcpu->arch.sie_block);
>  
> -     return vcpu;
> +     return 0;
> +
>  out_free_sie_block:
>       free_page((unsigned long)(vcpu->arch.sie_block));
> -out_uninit_vcpu:
> -     kvm_vcpu_uninit(vcpu);
> -out_free_cpu:
> -     kmem_cache_free(kvm_vcpu_cache, vcpu);
> -out:
> -     return ERR_PTR(rc);
> +     return rc;

This is getting a bit hard to follow across the patches, but I think rc
is now only set for ucontrol guests. So this looks correct right now,
but feels a bit brittle... should we maybe init rc to 0 and always
return rc instead?

>  }
>  
>  int kvm_arch_vcpu_runnable(struct kvm_vcpu *vcpu)

Otherwise, looks good.

_______________________________________________
kvmarm mailing list
kvmarm@lists.cs.columbia.edu
https://lists.cs.columbia.edu/mailman/listinfo/kvmarm

Reply via email to